package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^\s+map_K.\s+)([^\x00-\x1F\x7C]+)$`)
var str = ` map_Ks ./CarbonFiber_T.tga`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}