#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:\bcase\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)|((?:\bdefault\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)"
Local $sString = "<?php" & @CRLF & _
"switch" & @CRLF & _
" ($this) {" & @CRLF & _
" case 'value':" & @CRLF & _
" echo "test";" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" case 'deux':" & @CRLF & _
" echo 'deux';" & @CRLF & _
" $f;" & @CRLF & _
" break;" & @CRLF & _
"" & @CRLF & _
" default:" & @CRLF & _
" // code..." & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
" for" & @CRLF & _
" ($i=0; $i < 10; $i++) {" & @CRLF & _
" $i ++;" & @CRLF & _
" break;" & @CRLF & _
" }" & @CRLF & _
" ?>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")