const regex = /((?:\bcase\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)|((?:\bdefault\b\s*[\s\S]*?)\Kbreak(\(|\s|;?)[1-9]?(\)?)+;)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\bcase\\b\\s*[\\s\\S]*?)\\Kbreak(\\(|\\s|;?)[1-9]?(\\)?)+;)|((?:\\bdefault\\b\\s*[\\s\\S]*?)\\Kbreak(\\(|\\s|;?)[1-9]?(\\)?)+;)', 'gm')
const str = `<?php
switch
(\$this) {
case 'value':
echo "test";
break;
case 'deux':
echo 'deux';
\$f;
break;
default:
// code...
break;
}
for
(\$i=0; \$i < 10; \$i++) {
\$i ++;
break;
}
?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}