#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Con.+ess|Pul.+ole|RSI.+|VPN.+ulse|test|Users)"
Local $sString = "Consultants Special Access" & @CRLF & _
"Consultants Special EX" & @CRLF & _
"Contractors Windows Users Special Access" & @CRLF & _
"Contractors Windows Users Special Dix" & @CRLF & _
"PulseSAMRole" & @CRLF & _
"RSI - GIB Users" & @CRLF & _
"RSI - IT Desktop Users" & @CRLF & _
"RSI - ORA Devtrack" & @CRLF & _
"RSI - VPN ArchiveContractor Users" & @CRLF & _
"RSI - VPN Contractor Mac Users" & @CRLF & _
"RSI - VPN Contractor Users" & @CRLF & _
"RSI - VPN Contractor Users(Pulse)" & @CRLF & _
"RSI - VPN ITSecurity Users" & @CRLF & _
"RSI - VPN Users" & @CRLF & _
"test" & @CRLF & _
"Users" & @CRLF & _
"Contract Users" & @CRLF & _
"VPN Contractor Pulse" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")