$re = '/[^"]$/m';
$str = '1,A,"apple"
2,B,"banana"
3,C,"cherry
4,D,"durian"
5,E,"elderberry
6,F,"Fanta™"
7,G,"grape
8,H,"honeydew"';
$subst = "$0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;