package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\s\(`)
var str = `Isla Vista (University of California, Santa Barbara)[2]
Carrollton (University of West Georgia)[2]
Dahlonega (North Georgia College & State University)[2]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}