using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\s(\d+)\s([\d+]{2}:[\d+]{2}:[\d+]{2})\s\w+.\w+\s(\w+)\[(\d+)\]";
string input = @"Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}