package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w+)\s(\d+)\s([\d+]{2}:[\d+]{2}:[\d+]{2})\s\w+.\w+\s(\w+)\[(\d+)\]`)
var str = `Jul 6 14:01:23 computer.name CRON[29440]: USER (good_user)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}