# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.+ (..:..).+$/$1/gm;t' <<< "Server message: 2022-10-15 23:56:07:028
"