use strict;
my $str = 'Server message: 2022-10-15 23:56:07:028
';
my $regex = qr/^.+ (..:..).+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";