#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9](([0-9]{0,2}(\.[0-9]{3})*)|[0-9]*)$"
Local $sString = "---- válidos" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"123" & @CRLF & _
"1.100" & @CRLF & _
"123.123" & @CRLF & _
"2.321.234.556.654" & @CRLF & _
"---- válidos sem o ponto separando os milhares (caso seja aceito)" & @CRLF & _
"12345" & @CRLF & _
"1100" & @CRLF & _
"---- inválidos" & @CRLF & _
"1.1" & @CRLF & _
"1.2345" & @CRLF & _
"0" & @CRLF & _
"012" & @CRLF & _
"...."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")