import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:\\G(?!\\A)|<p(?:\\s[^>]*)?\\sclass=\"(?:[^\"]*\\s)?c01[\\s\"])(?:(?!<p[\\s>]).)*?\\K\\.(?=.*?</p>)";
final String string = "<p class=\"c01 c02\">lorem ipsum. dolor sit. amet sed.</p>\n"
+ "<p class=\"c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>\n"
+ "<p class=\"c00 c01 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>\n"
+ "<p class=\"c00 c01-1 c02 c03 nnn>lorem ipsum. dolor sit. amet sed.</p>";
final String subst = "$0 #";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}