# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)//igm;t' <<< "ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
"