import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:ithelpdesk(?:|\\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\\d+))@gmail.com)";
final String string = "ithelpdesk458@gmail.com\n\n"
+ "ithelpdesk@gmail.com\n\n"
+ "deskserverithelp@gmail.com\n\n"
+ "itservicedeskhelp@gmail.com\n\n\n\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}