const regex = /((?:ithelpdesk(?:|\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\d+))@gmail.com)/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:ithelpdesk(?:|\\d+)|deskserverithelp|itservicedeskhelp|ithelpservice(?:|\\d+))@gmail.com)', 'igm')
const str = `ithelpdesk458@gmail.com
ithelpdesk@gmail.com
deskserverithelp@gmail.com
itservicedeskhelp@gmail.com
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);