const regex = /f\[([^]]*)\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('f\\[([^]]*)\\]', 'gm')
const str = `f[r@ndom t3xt] + [some r@ndom t3xt] + [f[more r@ndom t3xt] / f[more t3xt]]
f[] + [] + [f[] / f[]]`;
const subst = `f.__getitem__($1, x=x)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);