use strict;
my $str = 'f[r@ndom t3xt] + [some r@ndom t3xt] + [f[more r@ndom t3xt] / f[more t3xt]]
f[] + [] + [f[] / f[]]';
my $regex = qr/f\[([^]]*)\]/mp;
my $subst = 'f.__getitem__($1, x=x)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";