re = /{%\s+(\S+)\s+IF:[^}]+%}(?s)(.+?){%\s+\1\s+ENDIF\s+%}/m
str = '{% name IF: a EQUALS b %}
content
{% name ENDIF %}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end