import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bJCheckBox\\b\\s*(?!ckx[A-Z])\\w+";
final String string = "Valid examples:\n\n"
+ "private JCheckBox ckxTest = new JCheckBox();\n"
+ "public javax.swing.JCheckBox ckxTest;\n\n"
+ "Invalid examples:\n\n"
+ "private JCheckBox\n"
+ "abcTest;\n"
+ "private JCheckBox abcckxTest;\n"
+ "private JCheckBox ckx;\n"
+ "private JCheckBox a;\n"
+ "private JCheckBox ckxfoo; // no upper case 'F'\n"
+ "private JCheckBox abcTest = new JCheckBox();\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}