# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bJCheckBox\b\s*(?!ckx[A-Z])\w+"
test_str = ("Valid examples:\n\n"
"private JCheckBox ckxTest = new JCheckBox();\n"
"public javax.swing.JCheckBox ckxTest;\n\n"
"Invalid examples:\n\n"
"private JCheckBox\n"
"abcTest;\n"
"private JCheckBox abcckxTest;\n"
"private JCheckBox ckx;\n"
"private JCheckBox a;\n"
"private JCheckBox ckxfoo; // no upper case 'F'\n"
"private JCheckBox abcTest = new JCheckBox();\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.