# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"entry \d+: (?:(?!entry \d+: ).)*special.*?(?=\s*entry \d+: |$)"
test_str = ("entry 1: hello\n"
"entry 2: world\n"
"entry 3: this\n"
"is a multiline\n"
"that makes it hard\n"
"entry 4: here we have a special entry\n"
"entry 5: here\n"
"we\n"
"have \n"
"another special entry\n"
"in a multiline\n"
"entry 6: end")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.