package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^()]+) \(([^()]*)\).*\[([^][]*)]`)
var str = `2022-12-26 19:14:44 (13.7 Mb/s) - ‘somelibrary.min.js’ saved [1077022]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}