$re = '/^(\s*|(([^,:&]*[^,:&\s]+[^,:&]*)+:[^,:&]*,)*(([^,:&]*[^,:&\s]+[^,:&]*)+:[^,:&]*,?))$/m';
$str = 'url_domain:keskustelu.suomi24.fi,url_path:/matkailu/matkakohteet/aasia,layout:lg,categories:Matkailu,main_category:Matkailu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);