#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\$\d+(?:,\d+)*\.\d{2}\b"
Local $sString = "abc,dec,$123,34.00,abc abc,dec,$123,34,56.00,abc" & @CRLF & _
""
Local $sSubst = ""$0""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)