using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]{2}-\d{2}-Annual\sDSH\sAudit\.pdf$";
string input = @"A-14-Annual DSH Audit.pdf
AL-13-Annual DSH Audit.pdf
AL-1-Annual DSH Audit.pdf";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}