$re = '/^[A-Z]{2}-\d{2}-Annual\sDSH\sAudit\.pdf$/m';
$str = 'A-14-Annual DSH Audit.pdf
AL-13-Annual DSH Audit.pdf
AL-1-Annual DSH Audit.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);