package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(\w)\()?(\w)`)
var str = `a(b
a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}