package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9].*[0-9])`)
var str = `T: +123 12 21 2123 111 | justasimplestring`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}