$re = '/([0-9].*[0-9])/m';
$str = 'T: +123 12 21 2123 111 | justasimplestring';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);