#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?![ ])(?!.*[ ]{2})((?:e|da|do|das|dos|de|d'|D'|la|las|el|los)\s*?|(?:[A-Z][^\s]*\s*?)(?!.*[ ]$))+$"
Local $sString = "Maria Silva" & @CRLF & _
"Maria silva" & @CRLF & _
"maria Silva" & @CRLF & _
"MariaSilva" & @CRLF & _
" Maria Silva" & @CRLF & _
"Maria Silva " & @CRLF & _
"Maria da Silva" & @CRLF & _
"Marina Silva" & @CRLF & _
"Maria / Silva" & @CRLF & _
"Maria . Silva" & @CRLF & _
"Maria Silva" & @CRLF & _
"Maria G. Silva" & @CRLF & _
"Maria McDuffy" & @CRLF & _
"Getúlio Dornelles Vargas" & @CRLF & _
"Maria das Flores" & @CRLF & _
"John Smith" & @CRLF & _
"John D'Largy" & @CRLF & _
"John Doe-Smith" & @CRLF & _
"John Doe Smith" & @CRLF & _
"Hector Sausage-Hausen" & @CRLF & _
"Mathias d'Arras" & @CRLF & _
"Martin Luther King Jr." & @CRLF & _
"Ai Wong" & @CRLF & _
"Chao Chang" & @CRLF & _
"Alzbeta Bara" & @CRLF & _
"Marcos Assunção" & @CRLF & _
"Maria da Silva e Silva" & @CRLF & _
"Juscelino Kubitschek de Oliveira" & @CRLF & _
"Natalia maria" & @CRLF & _
"Natalia aria" & @CRLF & _
"Natalia orea" & @CRLF & _
"Maria dornelas" & @CRLF & _
"Samuel eto'" & @CRLF & _
"Maria da Costa e Silva" & @CRLF & _
"Samuel Eto'o" & @CRLF & _
"María Antonieta de las Nieves"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")