$re = '/(\btotal\b)(?!.*[\r\n]*.*\1)/m';
$str = 'something total abc
total
foo total anything here
total
Anything total done!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);