// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)kafka.(.+)<type=(.+)-metrics,client-id=(.+),topic=(.+),partition=(.+)").unwrap();
let string = "kafka.producer<type=producer-topic-metrics,client-id=clientid,topic={topic},partition={partition}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}