re = /\bVores\sref\.:\s\d+-\d+\s+(\w+)/m
str = 'ABC This is an example Vores ref.: 23244-2234 LW782837673 Test 2324324'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end