re = /^[1-9][^SLOIBZsloibz0-9][^SLOIBZsloibz][0-9]-?[^SLOIBZsloibz0-9][^SLOIBZsloibz][0-9]-?[^SLOIBZsloibz0-9][^SLOIBZsloibz0-9][0-9][0-9]$/m
str = '1EG4-TE5-MK73
1EG4TE5MK73
1SG4-TE5-MK73
0EG4-TE5-MK73'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end