re = /(\d{4}[-.()\/* ]*?(?:(?:x|ext)[:]?[ ]*\d+)?)/m
str = '8910 ext 234
1234 x 5
2345 x 019234
2345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end