// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}[-.()\/* ]*?(?:(?:x|ext)[:]?[ ]*\d+)?)").unwrap();
let string = "8910 ext 234
1234 x 5
2345 x 019234
2345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}