using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[^\/]*\/[^\/]*\/$";
string substitution = @"/";
string input = @"https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/
https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}