import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "\\/[^\\/]*\\/[^\\/]*\\/$";
        final String string = "https://www.reddit.com/r/RationalPsychonaut/comments/5m4rhv/a_satirical_blog_about_enlightenment_in_everyday/\n"
	 + "https://www.reddit.com/r/swift/comments/5mriaj/i_just_released_a_swift_wrapper_for_the_llvm_api/\n";
        final String subst = "/";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceAll(subst);
        
        System.out.println("Substitution result: " + result);
    }
}