re = /var (.*?)=function.*ZZZ/
str = 'var some_fnc1=function(a,b,c){var a = 1+1;b=a++;c=b+a;}var some_fnc2=function(a){some();and_one(a) return false;}var some_fnc3=function(z,x,y){new AnySome(/sdds/i);var ZZZ=1;}var some_fnc4=function(ololo){var b = 1+1;b=z++;c=b+a;}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end