import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(cla20.*)(\\.h)";
final String string = "#include \"cla20ioh.h\"\n"
+ "#include \"cla20uth.h\"\n"
+ "#include \"cla20gch.h\"\n"
+ "#include \"cla20fnh.h\"";
final String subst = "\\U\\1\\E\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}