use strict;
my $str = '#include "cla20ioh.h"
#include "cla20uth.h"
#include "cla20gch.h"
#include "cla20fnh.h"';
my $regex = qr/(cla20.*)(\.h)/mp;
my $subst = '\\U\\1\\E\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";