# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(cla20.*)(\.h)"
test_str = ("#include \"cla20ioh.h\"\n"
"#include \"cla20uth.h\"\n"
"#include \"cla20gch.h\"\n"
"#include \"cla20fnh.h\"")
subst = "\\U\\1\\E\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.