re = /^\/(?:scripts\/my_app\/|(?!scripts\/)).*/m
str = '/scripts/my_app/
/scripts/my_app/xxxx.sh
/scripts/my_app/yyyyy/xxxz.sh
/scripts/
/scripts/another_string/xxxx.sh
/xxxx/yyyy/zzzzz/qqqq.sh
/aaaa/bbbb/ccc.sh'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end