re = /((?:(?<=[+\-*\/^%()])-)?\d+(?!\d)|[+\-*\/^%()])(?!$)/
str = '(5+4+8--5)+(5^-2/(-23%2))'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result