package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https:\/\/((coolhost)\.s3\.us-west-2\.amazonaws\.com(\/)|s3-us-west-2\.amazonaws\.com\/)(bucket1|bucket2)(-([0-9]+)|)\/([\w\/\-?=%.]+)`)
var str = `https://coolhost.s3.us-west-2.amazonaws.com/bucket1/dir1/dir3/file.jpeg
https://s3-us-west-2.amazonaws.com/bucket2/dir/filename.png`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}