$re = '/"(?<quote>(?:[^"\\\\]|(?:\\\\["\\\\])*)*)"/m';
$str = 'The man over there said "Ok, it\'s done!" and then "Yea!"
But, really what he meant was "Yea, \\"Like hell!\\", y\'know?\\\\"
""
"\\""
"\\\\"
"\\\\\\""
"\\\\\\\\\\\\"
"\\\\\\\\"
"\\a"
"\\"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);