using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)";
string substitution = @"<u>$1$2</u>";
string input = @"flyertalk.com <a href=""HTTPS://flyertalk.com"">Flyer Talk website</a>
Forum <a href=""HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/"">Delta</a>
----- <a href=""HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/"">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href=""HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx"">TUB</a> FLYER";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}