use strict;
my $str = 'flyertalk.com <a href="HTTPS://flyertalk.com">Flyer Talk website</a>
Forum <a href="HTTPS://www.flyertalk.com/forum/delta-air-lines-skymiles-665/">Delta</a>
----- <a href="HTTPS://www.flyertalk.com/forum/american-airlines-aadvantage-733/">AAA</a>
<u>Pneu</u> FLYER
- FLYER 40-622 <a href="HTTPS://www.veloplus.ch/AlleProdukte/Reifen/CityTourAlltag.aspx">TUB</a> FLYER';
my $regex = qr/(?<=>[^<]*)(flyer)|(flyer)(?=[^>]*<)/ip;
my $subst = '<u>$1$2</u>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";