^start of string
Group 1(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) 0-5one character from 0 (4810) to 5 (5310)
2nd Alternative2[0-4][0-9] 2the literal 2 (5010 / 628 / 3216)
0-4one character from 0 (4810) to 4 (5210)
0-9one character from 0 (4810) to 9 (5710)
3rd Alternative[01]?[0-9][0-9]? ?matches at most one character from the set below:
0the literal 0 (4810 / 608 / 3016)
1the literal 1 (4910 / 618 / 3116)
0-9one character from 0 (4810) to 9 (5710)
?matches at most one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
Group 2(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) 0-5one character from 0 (4810) to 5 (5310)
2nd Alternative2[0-4][0-9] 2the literal 2 (5010 / 628 / 3216)
0-4one character from 0 (4810) to 4 (5210)
0-9one character from 0 (4810) to 9 (5710)
3rd Alternative[01]?[0-9][0-9]? ?matches at most one character from the set below:
0the literal 0 (4810 / 608 / 3016)
1the literal 1 (4910 / 618 / 3116)
0-9one character from 0 (4810) to 9 (5710)
?matches at most one character from the set below:
0-9one character from 0 (4810) to 9 (5710)
\.the literal . (4610 / 568 / 2E16)
Group 3(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) 0-5one character from 0 (4810) to 5 (5310)
2nd Alternative2[0-4][0-9] 2the literal 2 (5010 / 628 / 3216)
0-4one character from 0 (4810) to 4 (5210)
3rd Alternative[01]?[0-9][0-9]? \.the literal . (4610 / 568 / 2E16)
Group 4(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?) $end of string
Oracle Software Owner for Each Oracle Software Product
You can create a single user the literal text Oracle Software Owner for Each Oracle Software Product↵↵You can create a single user (case sensitive) Group 5(for example, oracle) to own both Oracle Database, and
Oracle Restart installationsthe literal text to own both Oracle Database, and↵↵Oracle Restart installations (case sensitive) .any character (except for line terminators)
However, Oracle recommends that you create one software owner to own each Oracle
software installation the literal text ↵↵However, Oracle recommends that you create one software owner to own each Oracle↵↵software installation (case sensitive) Group 6(typically, oracle, for the database software and grid for the
Oracle Restart owner user) .any character (except for line terminators)
You must create at least one software owner the first time you install Oracle software
on the systemthe literal text ↵↵You must create at least one software owner the first time you install Oracle software↵↵on the system (case sensitive) .any character (except for line terminators)
Note:
In Oracle documentation, a user created to own only Oracle Grid
Infrastructure software installations is called the grid userthe literal text ↵↵Note:↵↵In Oracle documentation, a user created to own only Oracle Grid↵↵Infrastructure software installations is called the grid user (case sensitive) .any character (except for line terminators)
A user created to
own either all Oracle installations, or only Oracle database installations, is
called the oracle userthe literal text A user created to↵↵own either all Oracle installations, or only Oracle database installations, is↵↵called the oracle user (case sensitive) .any character (except for line terminators)
Standard Oracle Database Groups for Job Role Separation
Review the standard Oracle Database groupsthe literal text ↵↵Standard Oracle Database Groups for Job Role Separation↵↵Review the standard Oracle Database groups (case sensitive) .any character (except for line terminators)
The following is a list of standard Oracle Database groupsthe literal text ↵↵The following is a list of standard Oracle Database groups (case sensitive) .any character (except for line terminators)
These groups provide
operating system authentication for database administration system privileges:
Note:
All these groups are automatically created as a part of Oracle Database
installation on Windowsthe literal text These groups provide↵↵operating system authentication for database administration system privileges:↵↵Note:↵↵All these groups are automatically created as a part of Oracle Database↵↵installation on Windows (case sensitive) .any character (except for line terminators)
• The OSDBA group the literal text ↵↵• The OSDBA group (case sensitive)
Use this group the first time you install Oracle Database software on the systemthe literal text ↵↵Use this group the first time you install Oracle Database software on the system (case sensitive) .any character (except for line terminators)
This group identifies operating system user accounts that have database
administrative privileges the literal text ↵↵This group identifies operating system user accounts that have database↵↵administrative privileges (case sensitive) Group 8(the SYSDBA privilege) for all database instances running
on the serverthe literal text for all database instances running↵↵on the server (case sensitive) .any character (except for line terminators)
Members of the ORA_DBA group do not have SYSASM privileges on Oracle ASM
instances, which are needed for mounting and dismounting disk groupsthe literal text ↵↵Members of the ORA_DBA group do not have SYSASM privileges on Oracle ASM↵↵instances, which are needed for mounting and dismounting disk groups (case sensitive) .any character (except for line terminators)
• The OSOPER group for Oracle Database the literal text ↵↵• The OSOPER group for Oracle Database (case sensitive)
Use this group if you want a separate group of operating system users to have a
limited set of database administrative privileges for starting up and shutting down
the database the literal text ↵↵Use this group if you want a separate group of operating system users to have a↵↵limited set of database administrative privileges for starting up and shutting down↵↵the database (case sensitive) Group 10(the SYSOPER privilege) .any character (except for line terminators)
• The OSDBA group for a particular Oracle home the literal text ↵↵• The OSDBA group for a particular Oracle home (case sensitive) Group 11(ORA_HOMENAME_DBA)
This group is created the first time you install Oracle Database software into a new
Oracle homethe literal text ↵↵This group is created the first time you install Oracle Database software into a new↵↵Oracle home (case sensitive) .any character (except for line terminators)
This group identifies operating system user accounts that have
Chapter 4
Creating Required Operating System Groups and Users
4-8the literal text This group identifies operating system user accounts that have↵↵Chapter 4↵↵Creating Required Operating System Groups and Users↵↵4-8 (case sensitive)