#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\/index(|\.[php|html|htm]\w+)$"
Local $sString = "/index" & @CRLF & _
"/index.html" & @CRLF & _
"/index.htm" & @CRLF & _
"/index.php" & @CRLF & _
"" & @CRLF & _
"/index.ph"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")